Opened 10 years ago

Closed 10 years ago

#2711 enhancement closed duplicate (duplicate)

ConnectionRefusedError doesn't provide any information about the connection that was refused

Reported by: Jonathan Lange Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

It's just constructed with information coming from an OSError by tcp.Client. However, Client knows where it's trying to connect to, so it would be helpful and possible for the exception to include the host and port from Client.

Change History (2)

comment:1 Changed 10 years ago by therve

Resolution: duplicate
Status: newclosed

Duplicate of #2454.

comment:2 Changed 7 years ago by <automation>

Owner: Glyph deleted
Note: See TracTickets for help on using tickets.