Opened 11 years ago

Closed 10 years ago

#2698 defect closed duplicate (duplicate)

Build Bug on Cygwin

Reported by: donfanning Owned by: donfanning
Priority: low Milestone:
Component: core Keywords: cygwin
Cc: Branch:
Author:

Description (last modified by Jean-Paul Calderone)

It's a show stopper.... below is the skidmark...

running build
running build_py
running build_ext
gcc -fno-strict-aliasing -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -I/usr/include/python2.5 -c conftest.c -o conftest.o
building 'twisted.runner.portmap' extension
gcc -shared -Wl,--enable-auto-image-base build/temp.cygwin-1.5.24-i686-2.5/twisted/runner/portmap.o -L/usr/lib/python2.5/config -lpython2.5 -o build/lib.cygwin-1.5.24-i686-2.5/twisted/runner/portmap.dll
build/temp.cygwin-1.5.24-i686-2.5/twisted/runner/portmap.o: In function `portmap_set':
/home/Don/Twisted-2.5.0/TwistedRunner-0.2.0/twisted/runner/portmap.c:24: undefined reference to `_pmap_unset'
/home/Don/Twisted-2.5.0/TwistedRunner-0.2.0/twisted/runner/portmap.c:25: undefined reference to `_pmap_set'
build/temp.cygwin-1.5.24-i686-2.5/twisted/runner/portmap.o: In function `portmap_unset':
/home/Don/Twisted-2.5.0/TwistedRunner-0.2.0/twisted/runner/portmap.c:39: undefined reference to `_pmap_unset'
collect2: ld returned 1 exit status
error: command 'gcc' failed with exit status 1
Error: Subprocess exited with result 1 for project runner

Change History (6)

comment:1 Changed 11 years ago by donfanning

running build
running build_py
running build_ext
gcc -fno-strict-aliasing -DNDEBUG -g -O3 -Wall -Wstrict-prototypes -I/usr/include/python2.5 -c conftest.c -o conftest.o
building 'twisted.runner.portmap' extension
gcc -shared -Wl,--enable-auto-image-base build/temp.cygwin-1.5.24-i686-2.5/twisted/runner/portmap.o -L/usr/lib/python2.5/config -lpython2.5 -o build/lib.cygwin-1.5.24-i686-2.5/twisted/runner/portmap.dll
build/temp.cygwin-1.5.24-i686-2.5/twisted/runner/portmap.o: In function `portmap_set':
/home/Don/Twisted-2.5.0/TwistedRunner-0.2.0/twisted/runner/portmap.c:24: undefined reference to `_pmap_unset'
/home/Don/Twisted-2.5.0/TwistedRunner-0.2.0/twisted/runner/portmap.c:25: undefined reference to `_pmap_set'
build/temp.cygwin-1.5.24-i686-2.5/twisted/runner/portmap.o: In function `portmap_unset':
/home/Don/Twisted-2.5.0/TwistedRunner-0.2.0/twisted/runner/portmap.c:39: undefined reference to `_pmap_unset'
collect2: ld returned 1 exit status
error: command 'gcc' failed with exit status 1
Error: Subprocess exited with result 1 for project runner

comment:2 Changed 10 years ago by Glyph

Owner: changed from Glyph to donfanning
Priority: highlow

cygwin is currently not a supported platform, as we don't have a buildbot for it.

Please consider contributing a buildbot for http://twistedmatrix.com/buildbot/

If you write a patch which fixes this, it won't be rejected out of hand, but I doubt that any core developer will add ad-hoc untested support for a new platform (especially a new proprietary platform).

comment:3 Changed 10 years ago by Jean-Paul Calderone

Description: modified (diff)

reformatting description

comment:4 Changed 10 years ago by www.rzr.online.fr

Keywords: cygwin added
Milestone: Twisted-2.4
Priority: lownormal

Hi,

If it helps I tried on previous of twisted :

python ./setup.py install

2.4.0 : FAIL 2.2.0 : SUCEESS

BTW, This bug is affecting buildbot too :

https://sourceforge.net/tracker/?func=detail&atid=537004&aid=1792232&group_id=73177

More details may comes at :

http://rzr.online.fr/q/Cygwin

Regards

ps: python ./setup.py uninstall is welcome

comment:5 Changed 10 years ago by Jean-Paul Calderone

Milestone: Twisted-2.4
Priority: normallow

Still not a supported platform and no build slave nor patch has been forthcoming.

comment:6 Changed 10 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

This seems to be a duplicate of #1820 (which actually includes a proposed fix).

Note: See TracTickets for help on using tickets.