Opened 7 years ago

Closed 7 years ago

#2636 defect closed duplicate (duplicate)

stdio.StandardIO breaks, readhack code in process.py to blame

Reported by: gtalvola Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

stdio.StandardIO under some conditions will erroneously detect a closed connection, preventing any further output to stdout. It has to do with the "readhack" code in process.py. I've attached a couple of scripts that should make the problem clear. Just run teststdout and notice that the two runs of stdout.py produce different output. Then, edit stdout.py to uncomment out the s._writer.enableReadHack = False line, and re-run it, and this time the output should agree.

I discovered the problem using Twisted 2.4.0, but the relevant parts of process.py look the same in the trunk, so I expect the problem is still there.

Attachments (2)

stdout.py (1015 bytes) - added by gtalvola 7 years ago.
teststdout (96 bytes) - added by gtalvola 7 years ago.

Download all attachments as: .zip

Change History (5)

Changed 7 years ago by gtalvola

Changed 7 years ago by gtalvola

comment:1 Changed 7 years ago by gtalvola

BTW, I'm using Python 2.4.1 on Fedora Core 3 with a 2.6.16.20 kernel, in case that matters.

comment:2 Changed 7 years ago by therve

  • Milestone Core-2.6 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

I think this a duplicate of #2259.

comment:3 Changed 3 years ago by <automation>

  • Owner glyph deleted
Note: See TracTickets for help on using tickets.