Opened 11 years ago

Closed 11 years ago

#2620 enhancement closed duplicate (duplicate)

distribution needs fixups for "setup.py bdist_rpm"

Reported by: mengel Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

There are a few minor problems that snag you if you try to use "setup.py bdist_rpm". 1) Most packages have name="..." values in their setup.py file that have spaces in them,

which kills the rpm conversion. Taking the blanks out works.

2) Twisted and TwistedRunner need MANIFEST files that list the .c files, otherwise when

bdist_rpm builds the default MANIFEST and copies the contents, the build fails due to lack of .c files.

With those changes, "python setup.py all bdist_rpm" appears to make working RPM's out of the whole distribution...

Change History (2)

comment:1 Changed 11 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Duplicate of #1696

comment:2 Changed 7 years ago by <automation>

Owner: Glyph deleted
Note: See TracTickets for help on using tickets.