Opened 11 years ago

Closed 11 years ago

#2600 enhancement closed duplicate (duplicate)

dtrial - specify which machines (platforms) should be used to execute tests

Reported by: Michael Schneider Owned by:
Priority: normal Milestone:
Component: trial Keywords:
Cc: Branch:
Author:

Description

Allow a set of trial tests to be executed on any platform (set of platforms) by keyword.

A keyword is simply a set of computeNodes.

This allows a developer to fix a bug a a specific platform when their development platform is different the machine causing the problems.

Change History (3)

comment:1 Changed 11 years ago by Glyph

I don't mind the feature here, but can we be a bit more specific about the terminology? This ticket alone refers to:

  • keywords
  • machines
  • platforms
  • "computeNodes"

I'd prefer that we have one standard term for a "thing you run trial tests on" and stick with that. If we have a way to run tests on an X, or on a group of X, let's just call the group of X a "group of X" rather than inventing another term.

comment:2 Changed 11 years ago by Jonathan Lange

Resolution: duplicate
Status: newclosed

Duplicate of #1784

comment:3 Changed 7 years ago by <automation>

Owner: Jonathan Lange deleted
Note: See TracTickets for help on using tickets.