Opened 11 years ago

Closed 11 years ago

#2577 enhancement closed duplicate (duplicate)

"twistd stop" plugin

Reported by: itamarst Owned by:
Priority: lowest Milestone:
Component: core Keywords:
Cc: Jean-Paul Calderone Branch:
Author:

Description

Plugin for twistd that opens a pid file and kills the process involved, and if it doesn't die after a while does kill -9.

twistd stop [--path twistd.pid]

Change History (3)

comment:1 Changed 11 years ago by Jean-Paul Calderone

Cc: Jean-Paul Calderone added

I think this is a duplicate of #823

comment:2 Changed 11 years ago by Glyph

Resolution: duplicate
Status: newclosed

I agree. And I don't think that it should necessarily be a plugin either, since it makes more sense to me to say

twistd --stop axiom foo.axiom

than it does to say

twistd stop --path foo.axiom/run/twistd.pid

comment:3 Changed 7 years ago by <automation>

Owner: Glyph deleted
Note: See TracTickets for help on using tickets.