Opened 7 years ago

Closed 7 years ago

#2559 defect closed duplicate (duplicate)

trial runs unit tests in an arbitrary order

Reported by: zooko Owned by:
Priority: normal Milestone:
Component: trial Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

It would sometimes be nice to run unit tests in a certain order, for example to test your hypothesis that one unit tests is screwing up the state of another. However, if you pass multiple tests on the command-line to trial, it will run them in an arbitrary order, perhaps by sticking them into a set and then iterating it, or the like.

Change History (2)

comment:1 Changed 7 years ago by therve

  • Resolution set to duplicate
  • Status changed from new to closed

I think it's a duplicate of #1948.

comment:2 Changed 3 years ago by <automation>

  • Owner jml deleted
Note: See TracTickets for help on using tickets.