Opened 11 years ago

Closed 6 years ago

#2507 defect closed worksforme (worksforme)

missing 'plugins' directory breaks trial

Reported by: mlum@… Owned by: mlum@…
Priority: high Milestone:
Component: trial Keywords:
Cc: Glyph, jesstess Branch:
Author:

Description (last modified by Jean-Paul Calderone)

I'm running 'trial buildbot' buildbot within the buildbot source. Running 'trial' is breaking in the following:

Traceback (most recent call last):
  File "/usr/local/bin/trial", line 24, in <module>
    run()
  File "/usr/local/lib/python2.5/site-packages/twisted/scripts/trial.py", line 341, in run
    suite = _getSuite(config)
  File "/usr/local/lib/python2.5/site-packages/twisted/scripts/trial.py", line 301, in _getSuite
    return loader.loadByNames(config['tests'], recurse)
  File "/usr/local/lib/python2.5/site-packages/twisted/trial/runner.py", line 635, in loadByNames
    for thing in sets.Set(things)]
  File "/usr/local/lib/python2.5/site-packages/twisted/trial/runner.py", line 592, in loadAnything
    return self.loadPackage(thing, recurse)
  File "/usr/local/lib/python2.5/site-packages/twisted/trial/runner.py", line 543, in loadPackage
    pkgobj = modules.getModule(package.__name__)
  File "/usr/local/lib/python2.5/site-packages/twisted/python/modules.py", line 762, in getModule
    return theSystemPath[moduleName]
  File "/usr/local/lib/python2.5/site-packages/twisted/python/modules.py", line 698, in __getitem__
    self._findEntryPathString(moduleObject)),
  File "/usr/local/lib/python2.5/site-packages/twisted/python/modules.py", line 651, in _findEntryPathString
    rval, modobj, pformat(self.importerCache))
AssertionError: '' for <module '__init__' from 'buildbot/__init__.pyc'> not in import cache {'/usr/local/bin': None,
 '/usr/local/bin/twisted/plugins': <imp.NullImporter object at 0x2aaaaab18100>,

Change History (8)

comment:1 Changed 11 years ago by Jean-Paul Calderone

Description: modified (diff)

Reformatting description

comment:2 Changed 11 years ago by Jonathan Lange

Component: coretrial
Owner: changed from Glyph to Jonathan Lange

Best to treat it as a trial bug at first.

mlum, which version of buildbot were you using?

comment:3 Changed 11 years ago by Glyph

Cc: Glyph added
Priority: normalhigh

It's really a bug in t.p.m, so I'm very interested as well.

comment:4 Changed 11 years ago by Jean-Paul Calderone

This may be related to #2005.

comment:5 Changed 11 years ago by Jean-Paul Calderone

Probably #2489 too.

comment:6 Changed 7 years ago by <automation>

Owner: Jonathan Lange deleted

comment:7 Changed 6 years ago by jesstess

Cc: jesstess added
Owner: set to mlum@…

The buildbot tests from the latest release run without issue with Twisted 11.0. Can someone speak up if this issue still exists for them?

comment:8 Changed 6 years ago by jesstess

Resolution: worksforme
Status: newclosed

I'm going to go ahead and close this since we can't reproduce on the latest version of Twisted, but mlum if you find that this is still an issue please don't hesitate to re-open the ticket.

Note: See TracTickets for help on using tickets.