Opened 8 years ago

Closed 5 years ago

#2459 enhancement closed fixed (fixed)

Put Twisted developer targetted documentation back on the website

Reported by: exarkun Owned by:
Priority: normal Milestone:
Component: website Keywords: documentation
Cc: thijs, spiv Branch: branches/devdocs-2459
(diff, github, buildbot, log)
Author: glyph Launchpad Bug:

Description (last modified by glyph)

All the docs which were moved to doc/development/ no longer appear anywhere on the website. Several people have been confused/upset to discover this.

Change History (18)

comment:1 Changed 6 years ago by thijs

  • Cc thijs added
  • Keywords documentation added
  • Priority changed from normal to high

Is this still an issue?(!)

comment:2 follow-up: Changed 6 years ago by exarkun

Yes. The contents of trunk/doc/development/ still appear nowhere on the website outside of the repository browser.

comment:3 in reply to: ↑ 2 Changed 6 years ago by thijs

  • Priority changed from high to highest

Replying to exarkun:

Yes. The contents of trunk/doc/development/ still appear nowhere on the website outside of the repository browser.

I'm not able to fix it but raising the priority.

comment:4 Changed 6 years ago by thijs

  • Owner changed from radix to thijs
  • Status changed from new to assigned

I'll add it to the wiki on TwistedDevelopment

comment:5 Changed 6 years ago by thijs

  • Keywords review added
  • Owner thijs deleted
  • Status changed from assigned to new

comment:6 Changed 6 years ago by glyph

  • Description modified (diff)
  • Keywords review removed
  • Owner set to thijs

Thanks, thijs, this is definitely progress - but it's not really a complete fix.

To be complete, the generated files (i.e. the .html files produced from these .xhtml files by lore) should be on the website somewhere, ideally in the same directory structure as the "howto" documentation.

comment:7 Changed 6 years ago by glyph

  • Description modified (diff)

Whoops, added this to the description when I meant to add it in the comment:

It should probably be possible for you to fix this. It may not currently be, but can you explain why not, so you can fix other lore-documentation issues?

comment:8 Changed 6 years ago by thijs

glyph, I'm not sure how and where the Apache configs are stored etc. This seems more like a task for the website maintainer that has access to the server configuration (and root access etc). Or maybe I'm missing something here?

comment:9 Changed 6 years ago by exarkun

  • Owner changed from thijs to radix
  • Priority changed from highest to normal

radix has the access and knowledge required.

comment:10 Changed 6 years ago by therve

#3555 has been closed as a duplicate of that, talking about doc/development/legal/contributor-agreement.xhtml.

comment:11 Changed 6 years ago by spiv

  • Cc spiv added

comment:12 Changed 5 years ago by glyph

The reason that this documentation isn't present on the website is that the script responsible for putting stuff on the website, admin/update-documentation.py, categorizes the documentation by subproject, and 'development' is not a subproject.

This problem was caused by the solution to ticket #1617, which created this new directory. While separating out development documentation into its own category is a good idea, doing it in this particular way is problematic. This also means that the development documentation is not released as part of any dot product.

I therefore propose that we move 'development' to be a subdirectory of doc/core so that it is released with twisted core and put onto the website into the core category.

comment:13 Changed 5 years ago by glyph

  • Author set to glyph
  • Branch set to branches/devdocs-2459

(In [26950]) Branching to 'devdocs-2459'

comment:14 Changed 5 years ago by glyph

  • Keywords review added
  • Owner changed from radix to glyph

build results

Moved the development directory into core and added a link to it from the core index.

comment:15 Changed 5 years ago by glyph

  • Owner glyph deleted

comment:16 Changed 5 years ago by therve

  • Keywords review removed
  • Owner set to glyph

Seems correct, please merge.

comment:17 Changed 5 years ago by glyph

  • Resolution set to fixed
  • Status changed from new to closed

(In [27002]) Make developer documentation subsidiary to the 'core' project, instead of off in its own weird directory.

Author: glyph

Reviewer: therve

Fixes #2459

Aside from just making the structure of the doc/ directory that much more normal, this will have two important effects:

  • the developer documentation will be present in the TwistedCore 9.0 release, and
  • the develpoer documentation will be accessible via the website after the 9.0 release.

comment:18 Changed 4 years ago by <automation>

  • Owner glyph deleted
Note: See TracTickets for help on using tickets.