Opened 8 years ago

Closed 8 years ago

#2450 defect closed duplicate (duplicate)

t.t.test_tcp.HalfClose3TestCase.testReadNotificationRaises failed

Reported by: ghazel Owned by:
Priority: low Milestone:
Component: core Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

OS X, python 2.3, selectreactor, twisted 2.4.0

[ERROR]: twisted.test.test_tcp.HalfClose3TestCase.testReadNotificationRaises

  File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/python2.3/site-packages/twisted/test/test_tcp.py", line 1124, in testReadNotificationRaises
    self.f.protocol.readConnectionLost = self.aBug
exceptions.AttributeError: 'NoneType' object has no attribute 'readConnectionLost'
-------------------------------------------------------------------------------

After running it again, the test passed.

Change History (3)

comment:1 Changed 8 years ago by exarkun

Duplicate of #1730

comment:2 Changed 8 years ago by exarkun

  • Resolution set to duplicate
  • Status changed from new to closed

comment:3 Changed 4 years ago by <automation>

  • Owner glyph deleted
Note: See TracTickets for help on using tickets.