Opened 7 years ago

Closed 7 years ago

#2445 defect closed duplicate (duplicate)

trial dumps on frame error

Reported by: gardnerpomper Owned by:
Priority: normal Milestone:
Component: trial Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description (last modified by exarkun)

I run the attached code and I get this stack dump:

===============================================================================
[ERROR]: sip_test.sipTest.testRegister

Traceback (most recent call last):
  File "/usr/bin/trial", line 24, in ?
    run()
  File "/usr/lib/python2.3/site-packages/twisted/scripts/trial.py", line 345, in run
    test_result = trialRunner.run(suite)
  File "/usr/lib/python2.3/site-packages/twisted/trial/runner.py", line 798, in run
    result.printErrors()
  File "/usr/lib/python2.3/site-packages/twisted/trial/reporter.py", line 297, in printErrors
    self._formatFailureTraceback)
  File "/usr/lib/python2.3/site-packages/twisted/trial/reporter.py", line 275, in _printResults
    self.write(formatter(*(content[1:])))
  File "/usr/lib/python2.3/site-packages/twisted/trial/reporter.py", line 265, in _formatFailureTraceback
    fail.frames, frames = self._trimFrames(fail.frames), fail.frames
  File "/usr/lib/python2.3/site-packages/twisted/trial/reporter.py", line 255, in _trimFrames
    last = newFrames[-1]
IndexError: list index out of range

Attachments (1)

sip_test.py (1.7 KB) - added by gardnerpomper 7 years ago.
very very simple sip unit test

Download all attachments as: .zip

Change History (4)

Changed 7 years ago by gardnerpomper

very very simple sip unit test

comment:1 Changed 7 years ago by exarkun

  • Description modified (diff)

comment:2 Changed 7 years ago by exarkun

  • Resolution set to duplicate
  • Status changed from new to closed

Looks like a duplicate of #1901 - testRegister in the attachment isn't defined to take self.

comment:3 Changed 3 years ago by <automation>

  • Owner jml deleted
Note: See TracTickets for help on using tickets.