Opened 8 years ago

Closed 6 years ago

#2444 enhancement closed wontfix (wontfix)

Merge Divmod.Sine sip.py into twisted.protocols.sip

Reported by: therve Owned by: washort
Priority: normal Milestone:
Component: core Keywords:
Cc: washort, itamarst, thijs Branch:
Author: Launchpad Bug:

Description

Maintenance has been done in Divmod repository for years. We should merge the code, but that requires to remove references to other Divmod projects (at least axiom and epsilon). Also tests should probably be updated.

Change History (4)

comment:1 Changed 8 years ago by itamarst

  • Cc itamarst added

Awesome, glad you're doing this. Random notes on current pass, though I'm sure you're already aware of some:

  1. Coding standard violations (use of _).
  2. Replace exarkun@… with @example.com addresses.
  3. Are we aiming for backwards compat with old code, or just assuming no one used it?
  4. The comments in respondToAuthChallenge about bugs and the hardcoded asterisk stuff are disturbing :) Can you expand on this, washort?

comment:2 Changed 6 years ago by thijs

  • Cc thijs added
  • Owner changed from therve to washort

Assigning back to washort, and wondering where this code can be found?

comment:3 Changed 6 years ago by exarkun

#3533 was a duplicate of this.

comment:4 Changed 6 years ago by washort

  • Resolution set to wontfix
  • Status changed from new to closed

This isn't going to happen, exactly. The code in Sine is poorly tested and doesn't conform to the spec in certain ways.The transport and transaction layers have been reimplemented in #3584. The proxy and registrar will be done under #3662.

Note: See TracTickets for help on using tickets.