Opened 11 years ago

Closed 11 years ago

#2397 defect closed duplicate (duplicate)

missing attribute causing a traceback when running trial

Reported by: jacques Owned by:
Priority: normal Milestone:
Component: trial Keywords:
Cc: Branch:
Author:

Description

trial nevow.test Traceback (most recent call last):

File "/usr/local/lib/python2.5/site-packages/twisted/python/usage.py", line 199, in parseOptions

self.postOptions()

File "/usr/local/lib/python2.5/site-packages/twisted/scripts/trial.py", line 279, in postOptions

selfreporter? = self._loadReporterByName(selfreporter?)

File "/usr/local/lib/python2.5/site-packages/twisted/scripts/trial.py", line 265, in _loadReporterByName

for p in plugin.getPlugins(itrial.IReporter):

File "/usr/local/lib/python2.5/site-packages/twisted/plugin.py", line 227, in getPlugins

allDropins = getCache(package)

--- <exception caught here> ---

File "/usr/local/lib/python2.5/site-packages/twisted/plugin.py", line 178, in getCache

provider = namedAny(module.name + '.' + moduleName)

File "/usr/local/lib/python2.5/site-packages/twisted/python/reflect.py", line 357, in namedAny

topLevelPackage = import(trialname)

File "/usr/local/lib/python2.5/site-packages/twisted/plugins/twisted_web2.py", line 7, in <module>

from twisted.web2.iweb import IResource

File "/usr/local/lib/python2.5/site-packages/twisted/web2/iweb.py", line 58, in <module>

class IOldNevowResource(components.Interface):

exceptions.AttributeError: 'module' object has no attribute 'Interface'

Change History (2)

comment:1 Changed 11 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Duplicate of #2398

comment:2 Changed 7 years ago by <automation>

Owner: Jonathan Lange deleted
Note: See TracTickets for help on using tickets.