Opened 8 years ago

Closed 8 years ago

#2369 defect closed duplicate (duplicate)

twisted.python.versions is broken with svn 1.4

Reported by: psino Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

Since the format of .svn/entries changed, it cant determine the svn-version number anymore. Making a patch for this should be pretty trivial (if you want me to post a patch for this, just say so ;) ).

Considering it pretty severe (at least for me), as if the project root ever is imported (where version is usually imported) results in a traceback, and a failed import.

Traceback:

Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File "projectname/__init__.py", line 5, in ?
    version = str(version)
  File "/home/psino/Twisted/trunk/twisted/python/versions.py", line 63, in __str__
    return '[%s, version %d.%d.%d%s]' % (
  File "/home/psino/Twisted/trunk/twisted/python/versions.py", line 98, in _formatSVNVersion
    ver = self._getSVNVersion()
  File "/home/psino/Twisted/trunk/twisted/python/versions.py", line 90, in _getSVNVersion
    doc = parse(file(ent)).documentElement
  File "/usr/lib/python2.4/site-packages/_xmlplus/dom/minidom.py", line 1915, in parse
    return expatbuilder.parse(file)
  File "/usr/lib/python2.4/site-packages/_xmlplus/dom/expatbuilder.py", line 930, in parse
    result = builder.parseFile(file)
  File "/usr/lib/python2.4/site-packages/_xmlplus/dom/expatbuilder.py", line 207, in parseFile
    parser.Parse(buffer, 0)
xml.parsers.expat.ExpatError: syntax error: line 1, column 0

Change History (2)

comment:1 Changed 8 years ago by ralphm

  • Resolution set to duplicate
  • Status changed from new to closed

Identical duplicate of #2368, that was a dupe itself.

comment:2 Changed 4 years ago by <automation>

  • Owner glyph deleted
Note: See TracTickets for help on using tickets.