Opened 11 years ago

Closed 11 years ago

#2335 defect closed duplicate (duplicate)

Process leaks file descriptors in the presence of errors

Reported by: eric.newton Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

In twisted/internet/process.py, Twisted 2.4.0 on Linux w/2.6-smp Kernel.

multiple calls to os.pipe() are not protected against failures to allocate all the requested file descriptors, resulting in leakes that can bring down an entire server.

I get this when running as many processes in parallel as I possibly can.

Patch attached.

-Eric ecn AT zenoss c0m

Attachments (1)

t (2.5 KB) - added by eric.newton 11 years ago.
patch that cleans up file descriptors

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by eric.newton

Attachment: t added

patch that cleans up file descriptors

comment:1 Changed 11 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

This is a duplicate of #2305. Thanks for the patch, I'll make a note on the other ticket that it is here.

comment:2 Changed 7 years ago by <automation>

Owner: Glyph deleted
Note: See TracTickets for help on using tickets.