Opened 8 years ago

Closed 6 years ago

#2307 enhancement closed fixed (fixed)

rewrite setup.py so it doesn't os.system() other setup.py scripts

Reported by: radix Owned by:
Priority: normal Milestone: twisted-8.0
Component: release management Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

Instead, it should be closer to a regular setup.py scripts, perhaps importing information from subproject specifications, and actually calling distutils.setup *once* (If possible) or perhaps multiple times, but definitely in a smarter way.

More information will be given before implementation commences.

Change History (5)

comment:1 Changed 8 years ago by radix

  • Component changed from core to release management

comment:2 Changed 7 years ago by radix

  • Milestone changed from Core-2.6 to twisted-7.0

comment:3 Changed 6 years ago by radix

I was considering marking this as duplicate of #1286, but I'll leave it separate because they represent different requirements. However, the branch in #1286 is likely to fix this ticket.

comment:4 Changed 6 years ago by radix

  • Resolution set to fixed
  • Status changed from new to closed

It's done.

comment:5 Changed 3 years ago by <automation>

  • Owner radix deleted
Note: See TracTickets for help on using tickets.