Opened 10 years ago

Closed 10 years ago

#2272 enhancement closed duplicate (duplicate)

epytext errors in svn trunk, set up pydoctor buildbot

Reported by: Michael Hudson-Doyle Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

exarkun killed all of these a while back, but like weeds they are returning:

epytext error in Module 'twisted.python.modules'
epytext error in TwistedFunction 'twisted.python.modules._ModuleIteratorHelper.__getitem__'
epytext error in TwistedFunction 'twisted.protocols.smtp.encode_base64'
epytext error in TwistedFunction 'twisted.vfs.backends.adhoc.AdhocDirectory.child'
epytext error in TwistedFunction 'twisted.vfs.backends.inmem.FakeDirectory.child'
epytext error in TwistedFunction 'twisted.vfs.ivfs.IFileSystemContainer.child'
epytext error in TwistedFunction 'twisted.words.protocols.jabber.client.XMPPClientFactory'
epytext error in TwistedClass 'twisted.words.xish.domish.Element'
epytext error in TwistedClass 'twisted.web2.dav.xattrprops.xattrPropertyStore'
epytext error in TwistedClass 'twisted.web2.dav.resource.DAVPropertyMixIn'
epytext error in TwistedFunction 'twisted.web2.client.http.EmptyHTTPClientManager.clientPipelining'
epytext error in TwistedFunction 'twisted.web2.client.http.EmptyHTTPClientManager.clientPipelining'
epytext error in TwistedFunction 'twisted.web2.client.interfaces.IHTTPClientManager.clientPipelining'
epytext error in TwistedFunction 'twisted.web2.client.interfaces.IHTTPClientManager.clientPipelining'
epytext error in TwistedFunction 'twisted.mail.maildir.StringListMailbox.listMessages'
epytext error in TwistedFunction 'twisted.mail.pop3.IMailbox.listMessages'
epytext error in TwistedFunction 'twisted.mail.pop3.Mailbox.listMessages'
epytext error in TwistedFunction 'twisted.internet._dumbwin32proc._findShebang'
epytext error in TwistedFunction 'twisted.spread.jelly.Jellyable.jellyFor'
epytext error in TwistedFunction 'twisted.spread.jelly.Jellyable.jellyFor'
epytext error in TwistedFunction 'twisted.spread.flavors.RemoteCopy.unjellyFor'
epytext error in TwistedFunction 'twisted.spread.flavors.RemoteCache.unjellyFor'
epytext error in TwistedFunction 'twisted.spread.jelly.Jellyable.jellyFor'
epytext error in TwistedFunction 'twisted.spread.jelly.Jellyable.jellyFor'
epytext error in TwistedFunction 'twisted.spread.jelly.Unjellyable.unjellyFor'

Probably not that hard to fix, but more generally useful would be to set up a pydoctor buildbot that would turn red when this happens. I can donate time on a machine for this, but it needs to be done.

Change History (3)

comment:1 Changed 10 years ago by Glyph

Owner: changed from Glyph to Michael Hudson-Doyle

I certainly have no idea what could be done about this.

comment:2 Changed 10 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

#2640 is a duplicate of this, I suppose.

comment:3 Changed 6 years ago by <automation>

Owner: Michael Hudson-Doyle deleted
Note: See TracTickets for help on using tickets.