Opened 8 years ago

Closed 8 years ago

#2256 defect closed duplicate (duplicate)

test_tcp.HalfClose3TestCase.testReadNotificationRaisesTest fails sometimes on OSX

Reported by: jerub Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

On OSX, this will fail in anywhere from 1 to 10 test runs. Usually within about 3.

$ trial -u twisted.test.test_tcp.HalfClose3TestCase.testReadNotificationRaisesTest Pass 1
Running 1 tests.
twisted.test.test_tcp
  HalfClose3TestCase
    testReadNotificationRaises ...                                      [ERROR]

===============================================================================
[ERROR]: twisted.test.test_tcp.HalfClose3TestCase.testReadNotificationRaises

Traceback (most recent call last):
  File "/Users/stephen/src/Twisted/trunk/twisted/test/test_tcp.py", line 1288, in testReadNotificationRaises
    self.f.protocol.readConnectionLost = self.aBug
exceptions.AttributeError: 'NoneType' object has no attribute 'readConnectionLost'
-------------------------------------------------------------------------------
Ran 1 tests in 0.029s

FAILED (errors=1)

Change History (4)

comment:1 Changed 8 years ago by mwh

Works for me (well, it passed 4000 times or so while I was changing a light bulb...).

More details? I'm using Bob's old build of 2.4.1...

comment:2 Changed 8 years ago by exarkun

This is definitely a real problem. It's a race which is only triggered on some platforms due to ordering issues in the platform TCP/IP stack.

Maybe different versions of OS X interact with this code differently, though? No one said which version of OS X they were using.

comment:3 Changed 8 years ago by exarkun

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #1730

comment:4 Changed 4 years ago by <automation>

  • Owner glyph deleted
Note: See TracTickets for help on using tickets.