Opened 11 years ago

Closed 6 years ago

Last modified 6 years ago

#2115 defect closed worksforme (worksforme)

manhole and exception

Reported by: synapsis Owned by: synapsis
Priority: normal Milestone:
Component: conch Keywords:
Cc: jesstess, synapsis Branch:
Author:

Description

I'm using manhole on Windows XP SP2, Twisted 2.4, Putty as the client.

After doing a:

raise SystemExit()

from the terminal, the prompt ('>>>') does not appear any more. Moreover, every time I hit [RETURN] the same exception is re-raised in the program.

I have to hit Ctrl-C to obtain the prompt again.

Change History (4)

comment:1 Changed 6 years ago by <automation>

Owner: z3p deleted

comment:2 Changed 6 years ago by jesstess

Cc: jesstess synapsis added
Keywords: manlio.perillo@gmail.com removed
Owner: set to synapsis

Belatedly, thanks for reporting this synapsis. I wasn't able to reproduce this on Windows XP (or OS X or Linux) with Twisted 11.0. Is this still an issue in your environment?

comment:3 Changed 6 years ago by jesstess

Resolution: worksforme
Status: newclosed

I'm going to go ahead and close this since we can't reproduce on the latest version of Twisted, but synapsis if you find that this is still an issue please don't hesitate to re-open the ticket.

comment:4 Changed 6 years ago by synapsis

Ok.

Right now I don't have a Windows box ready, so I can not test the bug with the old Twisted versions and check that the bug is fixed with the latest version.

Note: See TracTickets for help on using tickets.