Opened 11 years ago

Closed 11 years ago

#2032 enhancement closed duplicate (duplicate)

"setup.py clean" does not remove all files after build

Reported by: rfmohr@… Owned by:
Priority: low Milestone:
Component: release management Keywords:
Cc: Branch:
Author:

Description

After running "python setup.py build" to build Twisted, I then ran "python setup.py clean" to remove all the files that were generated during the build. However, several were still left:

build/
twisted/__init__.pyc
twisted/copyright.pyc
twisted/_version.pyc
twisted/python/__init__.pyc
twisted/python/util.pyc
twisted/python/dist.pyc
twisted/python/versions.pyc
twisted/python/compat.pyc

I tried running the admin/clean command. It removed the *.pyc files, but it still left the build/ directory and also removed three xhtml files from doc that were needed:

doc/core/index.xhtml
doc/historic/index.xhtml
doc/pb/using-pb.xhtml

Change History (2)

comment:1 Changed 11 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

Duplicate of #2031

comment:2 Changed 7 years ago by <automation>

Owner: radix deleted
Note: See TracTickets for help on using tickets.