Opened 11 years ago

Closed 11 years ago

#1934 defect closed duplicate (duplicate)

twisted.web2.auth.wrapper.HTTPAuthResource problem

Reported by: yasusii Owned by: jknight
Priority: normal Milestone:
Component: web2 Keywords:
Cc: Branch:
Author:

Description

I tried doc/web2/examples/auth/httpauth.tac and got result as below.

$ twistd -y httpauth.tac
$ telnet localhost 8080
Trying 127.0.0.1...
Connected to localhost.localdomain.
Escape character is '^]'.
PROPFIND / HTTP/1.0

HTTP/1.1 405 Method Not Allowed

In this case, web server should return 401 UNAUTHORIZED.

Change History (2)

comment:1 Changed 11 years ago by troy@…

This looks very similar to the behavior reported in #1827.

comment:2 Changed 11 years ago by David Reid

Resolution: duplicate
Status: newclosed

This is a duplicate of #1827

Note: See TracTickets for help on using tickets.