Opened 11 years ago

Closed 11 years ago

#1932 enhancement closed duplicate (duplicate)

Make twisted installable with easy_install / setuptools

Reported by: philn Owned by: philn
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

I made a trivial patch to support setuptools for egg packaging. Next step would be to add dependency management in setup.py of subprojects. But this is a start, no?

Attachments (1)

twisted_setuptools.diff (1.1 KB) - added by philn 11 years ago.
Check kwext_modules? has regular content

Download all attachments as: .zip

Change History (6)

comment:1 Changed 11 years ago by Jean-Paul Calderone

Milestone: Twisted-2.5
Owner: changed from Glyph to philn

Tests? Yes, they'll probably be difficult to come up with, but since no core Twisted developer actually uses setuptools, they're absolutely essential in this case, otherwise there will be no indication when someone breaks support for this. I'd rather not support it at all than have support for it broken half the time.

comment:2 Changed 11 years ago by philn

I was pretty sure of this negative feedback. I don't see how Twisted Eggs should break better than "old school" installations... after all, eggs can be installed in directories (instead of zip files) and easy_install does a good job keeping its registry up-to-date.

If you don't want to add dependencies management, that's fine! I'd only like at least minimum setuptools support (implemented by attached patch).

Have you even tried it before saying it'd be broken half the time?

comment:3 Changed 11 years ago by Jean-Paul Calderone

Sorry, I don't think I made my point clear.

If no Twisted developers use the egg-based install, then no Twisted developer will notice when a Twisted developer changes something which breaks the egg-based install. So the egg-based install will be broken most of the time, because Twisted developers will keep breaking it without noticing.

I'm sure your patch is correct and not broken, I'm just not confident that Twisted developers will not change that fact inadvertently in the absence of automated test coverage.

Changed 11 years ago by philn

Attachment: twisted_setuptools.diff added

Check kwext_modules? has regular content

comment:4 Changed 11 years ago by radix

Summary: Setuptools supportMake twisted installable with easy_install / setuptools

I'm going to be working on this soon. I spent some time with Jim Fulton at pycon on this and we found out that Twisted can trivially be installed with easy_install after getting rid of the [True] hack in dist.py. First I'm going to investigate the original reason for this and hopefully find out that it is unnecessary. We may find a better way to work around it if it is still necessary.

I'm not totally sure but I think we may be able to get away with specifying dependencies by putting requires.txt files into our source distributions.

After I fix the [True] hack I will build some tarballs and get the zope community to test them.

comment:5 Changed 11 years ago by radix

Resolution: duplicate
Status: newclosed

Oh, I just noticed this is a duplicate of #1286.

Note: See TracTickets for help on using tickets.