Opened 12 years ago

Closed 9 years ago

Last modified 5 years ago

#1821 enhancement closed duplicate (duplicate)

Turn deferredgenerator wiki page into howto

Reported by: itamarst Owned by:
Priority: normal Milestone:
Component: website Keywords: documentation
Cc: Nicola Larosa, edsuom, Thijs Triemstra Branch:
Author:

Description


Attachments (1)

deferredgenerator-howto-1821.patch (10.0 KB) - added by Thijs Triemstra 9 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 12 years ago by Nicola Larosa

Cc: Nicola Larosa edsuom added
Owner: changed from Nicola Larosa to edsuom

The page would be this one?, I reckon. Reassigning to the documentation maintainer, edsuom.

comment:2 Changed 9 years ago by Thijs Triemstra

Cc: Thijs Triemstra added
Owner: changed from edsuom to Thijs Triemstra
Status: newassigned

comment:3 Changed 9 years ago by Itamar Turner-Trauring

There's also a duplicate ticket about deferredGenerator/inlineCallbacks howto.

comment:4 in reply to:  3 Changed 9 years ago by Thijs Triemstra

Replying to itamar:

There's also a duplicate ticket about deferredGenerator/inlineCallbacks howto.

Marked #2474 as a duplicate of this one.

Changed 9 years ago by Thijs Triemstra

comment:5 Changed 9 years ago by Thijs Triemstra

Keywords: review added
Owner: Thijs Triemstra deleted
Status: assignednew

See attached patch.

comment:6 Changed 9 years ago by Jean-Paul Calderone

Keywords: review removed
Owner: set to Thijs Triemstra
  • The use of the word intuitive in the introduction definitely has to go.
  • Using reactor.callLater is often confusing to people new to Deferreds. There should be some other event source here - eg, twisted.web.client.getPage
  • I'm not sure about the use of decorator syntax here. It should probably be replaced with manual decoration, although it may make sense to include at least one example using decorator syntax to help people who can't quite make the connection on their own. The Twisted coding standard forbids decorator syntax.
  • Only one of the code samples in this document can actually be run usefully. Runnable code is worth a lot more than dead examples.
  • The document needs to introduce the concepts which it will cover, explain what readers need to already be familiar with, and should include links to other related documents at the end.

It probably also makes sense to talk about inlineCallbacks here, since it's almost exactly the same. Most of the document can talk about one or the other and there can be one limited section that explains the correspondence between the two. It might be best if the majority of uses in the document are inlineCallbacks, since it requires less boilerplate.

comment:7 Changed 9 years ago by Jean-Paul Calderone

Resolution: duplicate
Status: newclosed

This is a duplicate of #1009.

comment:8 Changed 7 years ago by <automation>

Owner: Thijs Triemstra deleted

comment:9 Changed 5 years ago by Tom Prince

(In [37455]) Apply deferredgenerator-howto-1821.patch from thijs.

Refs #1009, #1821.

Note: See TracTickets for help on using tickets.