Opened 12 years ago

Closed 12 years ago

#1811 defect closed duplicate (duplicate)

setup.py bdist_rpm fails on FC5 for x86_64

Reported by: troy@… Owned by:
Priority: normal Milestone:
Component: core Keywords:
Cc: Branch:
Author:

Description

[troy@minas-tirith twisted-src-svn]$ ./setup.py bdist_rpm
running bdist_rpm
writing 'build/bdist.linux-x86_64/rpm/SPECS/Twisted.spec'
running sdist
warning: sdist: manifest template 'MANIFEST.in' does not exist (using default file list)
Traceback (most recent call last):
  File "twisted/topfiles/setup.py", line 107, in ?
    dist.setup(**setup_args)
  File "./twisted/python/dist.py", line 74, in setup
    return core.setup(**kw)
  File "/usr/lib64/python2.4/distutils/core.py", line 149, in setup
    dist.run_commands()
  File "/usr/lib64/python2.4/distutils/dist.py", line 946, in run_commands
    self.run_command(cmd)
  File "/usr/lib64/python2.4/distutils/dist.py", line 966, in run_command
    cmd_obj.run()
  File "/usr/lib64/python2.4/distutils/command/bdist_rpm.py", line 305, in run
    self.run_command('sdist')
  File "/usr/lib64/python2.4/distutils/cmd.py", line 333, in run_command
    self.distribution.run_command(command)
  File "/usr/lib64/python2.4/distutils/dist.py", line 966, in run_command
    cmd_obj.run()
  File "/usr/lib64/python2.4/distutils/command/sdist.py", line 143, in run
    self.get_file_list()
  File "/usr/lib64/python2.4/distutils/command/sdist.py", line 240, in get_file_list
    self.add_defaults()
  File "/usr/lib64/python2.4/distutils/command/sdist.py", line 301, in add_defaults
    self.filelist.extend(build_ext.get_source_files())
  File "/usr/lib64/python2.4/distutils/command/build_ext.py", line 371, in get_source_files
    self.check_extensions_list(self.extensions)
  File "/usr/lib64/python2.4/distutils/command/build_ext.py", line 304, in check_extensions_list
    (ext_name, build_info) = ext
TypeError: unpack non-sequence
Error: Subprocess exited with result 1 for project core

Change History (2)

comment:1 Changed 12 years ago by Glyph

Resolution: duplicate
Status: newclosed

Duplicate of #1696

comment:2 Changed 7 years ago by <automation>

Owner: Glyph deleted
Note: See TracTickets for help on using tickets.