Opened 12 years ago

Closed 12 years ago

#1767 enhancement closed duplicate (duplicate)

distutils' bdist_rpm fails (assuming it is not supported and requesting this as a feature)

Reported by: gopher Owned by:
Priority: lowest Milestone:
Component: core Keywords: package, rpm, distutils, setup
Cc: Branch:
Author:

Description

Running "python setup.py bdist_rpm" fails on Twisted-2.2.0 with errors originating in distutils' sdist handler. I assume that this is not supported, so far. However, using the auto-generated rpm .spec file to create a binary distribution works, so it might be easy to support the bdist_rpm handler.

Change History (4)

comment:1 Changed 12 years ago by gopher

Keywords: package rpm distutils setup added

comment:2 Changed 12 years ago by Jean-Paul Calderone

Twisted 2.4 is the current release. We don't even have a redhat packager, so I doubt we'll be fixing the packaging for a release that isn't even current. As it stands, I doubt we'll fix it for 2.4 either, unless someone from the community volunteers to take on this responsibility.

comment:3 Changed 12 years ago by Glyph

Resolution: duplicate
Status: newclosed

Duplicate of #1696

comment:4 Changed 7 years ago by <automation>

Owner: Glyph deleted
Note: See TracTickets for help on using tickets.