Opened 12 years ago

Closed 12 years ago

#1766 enhancement closed duplicate (duplicate)

distutils' bdist_rpm fails due to package naming

Reported by: gopher Owned by:
Priority: low Milestone:
Component: web Keywords: package, rpm, distutils, setup
Cc: gopher@… Branch:
Author:

Description

Running "python setup.py bdist_rpm" fails due to a misassumption of the setup script. When packaging TwistedWeb, rpmbuild reports "error: line 6: Tag takes single token only: Name: Twisted Web" while preparing the package. In addition, the resulting filename contains a space, which is untypical for packages. I've worked around this packaging error as I've changed the "name"-variable in setup.py to "TwistedWeb".

Change History (2)

comment:1 Changed 12 years ago by Glyph

Resolution: duplicate
Status: newclosed

Duplicate of #1696

comment:2 Changed 7 years ago by <automation>

Owner: jknight deleted
Note: See TracTickets for help on using tickets.