Opened 8 years ago

Closed 7 years ago

#1730 defect closed fixed (fixed)

twisted.test.test_tcp.HalfClose3TestCase.testReadNotificationRaises fails intermittently

Reported by: radix Owned by:
Priority: highest Milestone:
Component: core Keywords:
Cc: therve Branch:
Author: Launchpad Bug:

Description

At least on my x86/OS X machine.

  File "/Users/radix/tmp/lib/python2.4/site-packages/twisted/test/test_tcp.py", line 1124, in testReadNotificationRaises
    self.f.protocol.readConnectionLost = self.aBug
exceptions.AttributeError: 'NoneType' object has no attribute 'readConnectionLost'

Change History (8)

comment:1 Changed 8 years ago by exarkun

#2256 was a duplicate of this.

comment:2 Changed 7 years ago by exarkun

#2450 was a duplicate of this.

comment:3 Changed 7 years ago by exarkun

  • Priority changed from normal to high

This fails on Windows sometimes, too.

*bump*

comment:4 Changed 7 years ago by exarkun

  • Owner changed from jknight to exarkun
  • Status changed from new to assigned

comment:5 Changed 7 years ago by exarkun

  • Keywords review added
  • Owner exarkun deleted
  • Priority changed from high to highest
  • Status changed from assigned to new

Fails in trunk on neutron (OS X host) within 100 runs pretty reliably. In read-notification-raises-1730, ran 4000+ times without failing. Please review!

comment:6 Changed 7 years ago by therve

  • Cc therve added
  • Keywords review removed
  • Owner set to exarkun

That looks OK, I couldn't reproduce the problem anymore under my vmware win32 machine.

Just one thing: aBug mentions readConnectionLost, it should probably mention writeConnectionLost too.

comment:7 Changed 7 years ago by exarkun

  • Resolution set to fixed
  • Status changed from new to closed

(In [21268]) Merge read-notification-raises-1730

Author: exarkun
Reviewer: therve
Fixes #1730

Rewrite two unit tests for a feature of half-close support so that they
do not contain a race condition which sometimes results in the tests
failing due to setup having been only partially completed.

comment:8 Changed 3 years ago by <automation>

  • Owner exarkun deleted
Note: See TracTickets for help on using tickets.