Opened 8 years ago

Closed 6 years ago

#1614 defect closed duplicate (duplicate)

trial fails to set reactor.running flag

Reported by: landonf Owned by:
Priority: low Milestone:
Component: trial Keywords:
Cc: Branch:
Author: Launchpad Bug:

Description

Reproduction case:

from twisted.internet import reactor
from twisted.trial import unittest

class ReactorIsRunning(unittest.TestCase):
    def test_reactorIsRunning(self):
        self.failUnless(reactor.running)

Change History (3)

comment:1 Changed 8 years ago by jml

  • Priority changed from normal to low

comment:2 Changed 6 years ago by exarkun

  • Resolution set to duplicate
  • Status changed from new to closed

#3178 was a duplicate of this. It has a lot of discussion, so I'm closing this one as a duplicate instead, even though this one was filed first.

comment:3 Changed 4 years ago by <automation>

  • Owner jml deleted
Note: See TracTickets for help on using tickets.