Opened 9 years ago

Last modified 9 years ago

#1266 defect closed fixed (fixed)

trial excludes explicitly specified test modules

Reported by: exarkun Owned by:
Priority: highest Milestone:
Component: core Keywords:
Cc: exarkun, jml Branch:
Author: Launchpad Bug:

Description


Change History (7)

comment:1 Changed 9 years ago by exarkun

For example:

exarkun@boson:~$ cat foo.py
from twisted.trial import unittest

class Test(unittest.TestCase):
    def testfoo(self):
        print 'yep'
exarkun@boson:~$ trial foo.py 
Running 0 tests.

-------------------------------------------------------------------------------
Ran 0 tests in 0.000s

PASSED
exarkun@boson:~$

comment:2 Changed 9 years ago by jml

*gnrh*

comment:3 Changed 9 years ago by jml

I can't reproduce this :(


(jml@kaos ~) cat foo.py
from twisted.trial import unittest

class Test(unittest.TestCase):
    def testfoo(self):
        print 'yes'


(jml@kaos ~) trial foo.py
Running 1 tests.
  foo
    Test
      testfoo ... yes
                                                         [OK]

-------------------------------------------------------------------------------
Ran 1 tests in 0.116s

PASSED (successes=1)
(jml@kaos ~)

comment:4 Changed 9 years ago by exarkun

Apparently _this_ is the full required environment:

exarkun@boson:~$ cat > foo.py
from twisted.trial import unittest

class Test(unittest.TestCase):
    def testfoo(self):
        print 'yes'
exarkun@boson:~$ mkdir foo
exarkun@boson:~$ touch foo/__init__.py
exarkun@boson:~$ trial foo.py
Running 0 tests.

-------------------------------------------------------------------------------
Ran 0 tests in 0.000s

PASSED
exarkun@boson:~$

comment:5 Changed 9 years ago by jml

Duplicated.

comment:6 Changed 9 years ago by jml

Fixed in r14831.

comment:7 Changed 3 years ago by <automation>

  • Owner jml deleted
Note: See TracTickets for help on using tickets.