Opened 9 years ago

Closed 3 years ago

#1247 defect closed worksforme (worksforme)

kqreactor timeout error (traceback)

Reported by: ghazel Owned by: ghazel
Priority: high Milestone:
Component: conch Keywords:
Cc: ghazel, jesstess Branch:
Author: Launchpad Bug:

Description


Change History (5)

comment:1 Changed 9 years ago by ghazel

Just happens sometimes, often.

Traceback (most recent call last):
  ...
    reactor.run(installSignalHandlers=False)
  File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/
python2.3/site-packages/twisted/internet/posixbase.py", line 199, in run
    self.mainLoop()
  File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/
python2.3/site-packages/twisted/internet/posixbase.py", line 207, in
mainLoop
    self.runUntilCurrent()
--- <exception caught here> ---
  File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/
python2.3/site-packages/twisted/internet/base.py", line 533, in
runUntilCurrent
    call.func(*call.args, **call.kw)
  File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/
python2.3/site-packages/twisted/protocols/policies.py", line 428, in
__timedOut
    self.timeoutConnection()
  File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/
python2.3/site-packages/twisted/protocols/policies.py", line 434, in
timeoutConnection
    self.transport.loseConnection()
  File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/
python2.3/site-packages/twisted/internet/abstract.py", line 210, in
loseConnection
    self.stopReading()
  File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/
python2.3/site-packages/twisted/internet/abstract.py", line 224, in
stopReading
    self.reactor.removeReader(self)
  File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/
python2.3/site-packages/twisted/internet/kqreactor.py", line 116, in
removeReader
    self._updateRegistration(fd, EVFILT_READ, EV_DELETE)
  File "/System/Library/Frameworks/Python.framework/Versions/2.3/lib/
python2.3/site-packages/twisted/internet/kqreactor.py", line 89, in
_updateRegistration
    kq.kevent([kevent(*args)], 0, 0)
exceptions.OSError: [Errno 2] No such file or directory

comment:2 Changed 3 years ago by <automation>

comment:3 Changed 3 years ago by jesstess

  • Cc jesstess added
  • Component set to conch
  • Owner set to ghazel

Belatedly, thanks for reporting this, ghazel. Can you confirm that this issue still exists, and if so attach a self-contained example that triggers the error (even if it only happens sometimes)?

comment:4 Changed 3 years ago by ghazel

No, sorry, it's been 6 years and I'm not sure what bit of code raised this. Here's an identical exception though, with what might be suitable repro instructions:

http://twistedmatrix.com/pipermail/twisted-python/2008-April/017462.html

comment:5 Changed 3 years ago by jesstess

  • Resolution set to worksforme
  • Status changed from new to closed

Thanks for following up, ghazel. I'm going to go ahead and close this due to insufficient information to reproduce.

Ticket 1918 Revive KQueue Reactor is almost ready to land. We believe the issue from the mailing list related to daemonization is different from what you saw here, and that issue is specifically addressed in the branch for 1918.

Note: See TracTickets for help on using tickets.