Opened 9 years ago

Last modified 9 years ago

#1244 defect closed fixed (fixed)

iocpreator can drop a listening socket by mistake

Reported by: ghazel Owned by: justinj
Priority: high Milestone:
Component: core Keywords: win32
Cc: justinj, PenguinOfDoom, ghazel Branch:
Author: Launchpad Bug:

Description


Change History (3)

comment:1 Changed 9 years ago by ghazel

in iocpreactor\ops.py the ERROR_NETNAME_DELETED error is handled, but 
ERROR_SEM_TIMEOUT (=121) is not. Meaning if a timeout occurs, 
self.transport.acceptErr is called, dropping the listening port altogether.
I believe they should be handled exactly the same way (it works here).

There's no demo for this problem, because there's no sure-fire way to reproduce 
it (not all drivers use ERROR_SEM_TIMEOUT, and mine only does it under heavy 
load).

comment:2 Changed 9 years ago by justinj

I'm reassigning this to me.  Let me know if you have a problem with that.

comment:3 Changed 9 years ago by justinj

Fixed in r15084.
Note: See TracTickets for help on using tickets.