Opened 9 years ago

Closed 9 years ago

#1143 defect closed duplicate (duplicate)

Documentation: Aliases not covered in the API documentation

Reported by: moof Owned by:
Priority: high Milestone:
Component: mail Keywords: documentation
Cc: glyph, exarkun, spiv, hypatia, moof Branch:
Author: Launchpad Bug:

Description


Change History (5)

comment:1 Changed 9 years ago by moof

Aliases of the type:

#twisted/mail/POP3.py line 745
from twisted.mail.pop3client import POP3Client as AdvancedPOP3Client

are not covered in the API documentation. This is confusing when you're told to
use AdvancedPOP3Client by a DeprecationWarning, but this sort of thing may well
be happenning elsewhere, and it'd be useful to have a clue where some obejcts
come from sometimes.

comment:2 Changed 9 years ago by exarkun

This sounds like an epydoc problem.  AdvancedPOP3Client is in
twisted.mail.pop3's __all__, so the documentation for it should end up on
twisted.mail.pop3's page.

comment:3 Changed 9 years ago by glyph

Ugh.  Epydoc doesn't look like it's being maintained any more.  Should we start
a fork?

comment:4 Changed 9 years ago by exarkun

  • Component set to mail
  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #38.

comment:5 Changed 4 years ago by <automation>

  • Owner glyph deleted
Note: See TracTickets for help on using tickets.