Opened 9 years ago

Closed 7 years ago

#1089 defect closed fixed (fixed)

http proxy doesn't close connection after sending 'Could not connect'

Reported by: jeffsilver Owned by: therve
Priority: highest Milestone:
Component: web Keywords:
Cc: jknight, jeffsilver Branch:
Author: Launchpad Bug:

Description


Attachments (1)

1089.diff (918 bytes) - added by therve 7 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 9 years ago by jeffsilver

In web/proxy.py, ProxyClientFactory.clientConnectionFailed(), an error page is
sent to the client, but the connection is not closed.
I think this can be fixed by inserting:
    self.father.transport.loseConnection()
at the end of the method (but I'm not certain that this is clean).

comment:2 Changed 9 years ago by jeffsilver

I've included this fix in my patch for #1149

comment:3 Changed 7 years ago by therve

  • Component set to conch

#2922 has been closed as a duplicate of this.

comment:4 Changed 7 years ago by therve

  • Component changed from conch to web
  • Owner changed from jknight to therve

Changed 7 years ago by therve

comment:5 Changed 7 years ago by therve

  • Keywords review added
  • Owner therve deleted
  • Priority changed from high to highest

I think that doesn't deserver a branch :). Ready to review.

comment:6 Changed 7 years ago by exarkun

  • Keywords review removed
  • Owner set to therve

Beautiful, please merge.

comment:7 Changed 7 years ago by therve

  • Resolution set to fixed
  • Status changed from new to closed

(In [22159]) Close connection twisted.web.proxy.ProxyClientFactory when reporting a 501
error.

Author: therve
Reviewer: exarkun
Fixes #1089

Note: See TracTickets for help on using tickets.