Ticket #5683: zope.patch

File zope.patch, 1.1 KB (added by vperic, 4 years ago)

Update docs

  • INSTALL

    diff --git INSTALL INSTALL
    index 6c08d02..cb23d1f 100644
    Requirements 
    22
    33  Python 2.6 or 2.7.
    44
    5   Zope Interfaces 3.3.0 or better (http://pypi.python.org/pypi/zope.interface)
     5  Zope Interface 3.6.0 or better (http://pypi.python.org/pypi/zope.interface)
    66
    77  pyOpenSSL (<http://launchpad.net/pyopenssl>) is required for any SSL APIs.  On
    88  Windows, version 0.10 or newer is required.  pyOpenSSL 0.10 or newer is also
  • setup.py

    diff --git setup.py setup.py
    index 9e511b9..bc5878e 100755
    on event-based network programming and multiprotocol integration. 
    6262
    6363    if 'setuptools' in sys.modules:
    6464        from pkg_resources import parse_requirements
    65         requirements = ["zope.interface"]
     65        requirements = ["zope.interface>=3.6.0"]
    6666        try:
    6767            list(parse_requirements(requirements))
    6868        except:
  • new file twisted/topfiles/5683.feature

    diff --git twisted/topfiles/5683.feature twisted/topfiles/5683.feature
    new file mode 100644
    index 0000000..db28298
    - +  
     1The minimum required version of zope.interface is now 3.6.0.
     2 No newline at end of file