[Twisted-web] Web2 Script.py seems to be broken

James Y Knight foom at fuhm.net
Mon Feb 6 23:55:19 MST 2006

Indeed it is broken; in SVN twisted.web2.script currently starts with  
the line:

raise ImportError("FIXME: this file probably doesn't work.")

I think that fixes the particular problem you're seeing. ;)

There's no reason it should be hard to support .rpy files in web2,  
but nobody has done anything about it. Part of the reason being that  
RPYs have somewhat fallen out of favor and are generally discouraged.  
However, I do see that they're sometimes useful as a solution sort of  
in between CGI and internal code, so I wouldn't mind seeing support  
return. It's not on my list of things I want to do soon, though.


More information about the Twisted-web mailing list