[Twisted-web] does Nevow work with Twisted 2.x ?

jarrod roberson jarrod.roberson at gmail.com
Thu Mar 17 19:58:05 MST 2005

On Thu, 17 Mar 2005 18:02:54 -0500, Christopher Zorn
<christopher.zorn at gmail.com> wrote:
> On Wed, 16 Mar 2005 23:15:08 -0500, jarrod roberson
> <jarrod.roberson at gmail.com> wrote:
> > I guess the subject says it all, I have the latest Twisted from svn
> > and the latest Nevow from svn and I get lots of deprecation warnings
> > and can't get any of the examples actually work
> I have not looked at it much, but I can not get it to work either.
> For code that worked with twisted 1.3 and nevow 0.3 I get the following error
> Failed to load application: type.__new__(MetaTypedInterface):
> MetaTypedInterface is not a subtype of type
> I can post the entire thing if that will help, let me know.

Twisted 2.0 needs the zope.interface package

and I had to do a

from zope.interface import implements

and change all the __implements__ = to implements()

More information about the Twisted-web mailing list