[Twisted-web] Nevow trunk

James Y Knight foom at fuhm.net
Mon Apr 18 10:43:33 MDT 2005

Just a note for those not following commits closely: Nevow trunk (what 
will become 0.5) now requires zope-interface, and twisted 2.0.

For anyone trying to use Nevow without twisted installed at all, it's 
supposed to still work without twisted installed at all, but only if 
you convert your app to zope-interface style declarations, rather than 
twisted1.3 __implements__ style. Also, I don't know that anyone's 
tested it like that, so it probably doesn't work right now.

Also, if you get an error like this:
is not safe, use object.__new__()

that means your zope-interface package is 3.0, which is buggy, and you 
should install 3.0.1.


More information about the Twisted-web mailing list