[Twisted-Python] Epoll error after upgrading from 10.0 to 12.3

exarkun at twistedmatrix.com exarkun at twistedmatrix.com
Sun Mar 3 01:06:15 EST 2013

On 05:21 am, matusis at yahoo.com wrote:
>I had 60 busy tcp servers that ran on Python 2.6/Twisted 10.0 (or 
>9.0) for over two years with not problems. After I upgraded to Twisted
>12.3/Python 2.7, I started getting the errors below (no application 
>changes). It took about two days for the first error to appear on a 
>server under heavy load:
>After the error occurs, the server usually locks up and does not accept 
>connections. One server self-recovered after these errors after 30min
>outage, and started accepting new connections.
>Apparently I am not the ony one who has enountered this:
>Is there a patch available, or should I roll back to 10.0.0?

Doesn't look familiar to me.  You should search the bug tracker.  If 
there is a patch (or an svn branch), that's where you'll find it.  If 
you don't find a ticket for the bug, you should report it.  Please be 
sure to include enough information to reproduce the issue if you file a 
new ticket (or as much information as you have, at least).


More information about the Twisted-Python mailing list