[Twisted-Python] TypeError: Class advice impossible in Python3

exarkun at twistedmatrix.com exarkun at twistedmatrix.com
Sat Jan 12 22:29:54 EST 2013

On 03:15 am, abhishekbhat at hotmail.com wrote:
>Is there some sort of upper bound on when PB would be available for 
>Python3.3? I am hoping to use it for a Python3 project.

As with any development, it will happen when people do it. :)  Twisted 
development is almost entirely on a volunteer basis, and people mostly 
work on what they personally want to work on.

If you're wondering who's currently working on porting PB to Python 3, I 
don't think anyone is.
>Any proposals to switch from PB to Foolscap in the upcoming releases of 

No.  Foolscap is not backwards compatible with PB, so there won't be a 
switch from one to the other.  Fortunately, there's nothing that 
prevents you from ignoring PB and instead using Foolscap in any of your 
Twisted-based projects.


More information about the Twisted-Python mailing list