[Twisted-Python] [RFC] Introducing six as a dependency

Tobias Oberstein tobias.oberstein at tavendo.de
Fri Jul 27 06:32:12 EDT 2012

>>Even having full access to MSDN, it can be incredibly obscure to discover which Python version goes with which Visual Studio product.  (Someone, please prove me wrong and indicate that there's a web page that shows what the official python.org >> builds use and you don't have to go trawling through python-dev archives to figure it out...)

It is obscure. And I don't have a link, but the official Python on Windows builds are done using Microsoft Visual C++ 2008.

- VS 2010 will NOT work
- the free VS 2008 Express works (for 32-bit builds .. it does not include a 64-bit compiler)

To build Twisted working with official binary Python builds, the exact same compiler is needed: VS2008.

More information about the Twisted-Python mailing list