[Twisted-Python] connectionLost never reached after calling loseConnection: stuck in CLOSE_WAIT forever

Glyph Lefkowitz glyph at twistedmatrix.com
Sat Oct 16 23:16:35 EDT 2010

On Oct 16, 2010, at 11:22 AM, Stefano Debenedetti wrote:

> Does this sound familiar in any way? Any suggestions off top of head
> while I try to come up with a self-contained sample which is
> reliably reproducing the issue I'm seeing happening only "sometimes
> and quite seldom[TM]"?

I can't recall having seen this exact issue in the past, but as you've described it it sounds like you may have discovered a Twisted bug.  I'm looking forward to your example.

I do have a few questions:

What version of Twisted are you using?
Have you tried a more recent version? Trunk?
What reactor are you using?
Have you tried a different reactor?
What platform/OS are you on?  What version?
Have you tried a different platform?

I am also curious whether changing


   reactor.callLater(0, proto.transport.loseConnection)

makes any difference to your example.

Thanks, and good luck,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://twistedmatrix.com/pipermail/twisted-python/attachments/20101016/0d69effd/attachment.htm 

More information about the Twisted-Python mailing list