[Twisted-Python] Get Twisted 10.0 in to Ubuntu 10.04 LTS

Esteve Fernandez esteve at sindominio.net
Tue Mar 9 07:03:31 EST 2010

Hi Free

> Nice job. I can sponsor the upload to Debian, if that helps (I guess
> once all packages are in Debian we can request a sync, and it probably
> makes sense as anyway we want to eventually have them in Debian as
> well).

Thanks! However, there are some glitches in the packages you uploaded to Debian:

- they skipped 9.0.0-2, and thus #566395 and #566913 are open again
- python-twisted doesn't depend on >= 10.0.0, but >= 9.0

Those bugs were fixed in the packages in our PPA, though.

> ~% dpkg -c python-twisted-core_10.0.0-0\~ppa1\~lucid1_all.deb|grep
> _initgroups.so
> -rw-r--r-- root/root     15876 2010-03-08 15:27
> ./usr/lib/python2.6/dist-packages/twisted/python/_initgroups.so

Thanks, I didn't notice that, I should have read the NEWS file :-P

What should we do next? Can the currently packages in Debian be revoked or do
we have to prepare new ones?


More information about the Twisted-Python mailing list