[Twisted-Python] Regarding Ticket 3629, Error in adbapi Connection Pool in cleanup

Vishal Shetye vishalshetye at gmail.com
Fri Oct 30 09:27:16 EDT 2009

I was facing the issue as noted here http://twistedmatrix.com/trac/ticket/3629.
As I see, python 2.5 can be build with pysqlite2.1.3 and sqlite 3.0.8 or later.
However, support for a connection to be moved across multiple threads
was added to sqlite at version3.3.1.

Last comment in the ticket says, the module is just overprotective.
Which module is he referring to and why is it said that it is overprotective?
Is he referring to the pysqlite module?
He says using check_same_thread=False is safe, is he saying it
specifically in the twisted's context?
Is it really safe even if I am using sqlite version between 3.0.8 to 3.3.1?


More information about the Twisted-Python mailing list