[Twisted-Python] Running a GUI application based on PyQt

Itamar Shtull-Trauring itamar at itamarst.org
Mon Nov 24 08:28:18 EST 2008

On Mon, 2008-11-24 at 06:37 -0200, Nahuel Defossé wrote:
> I've tried the code posted in qt4reactor.py but it doesn't work. It fails 
> telling that a reactor's been already installed.
> Is it possible to use PyQt4 (v.4.4) with twisted?

Only import "twisted.internet.reactor" *after* you've installed
qt4reactor. Importing auto-installs reactor if one hasn't already been

More information about the Twisted-Python mailing list