[Twisted-Python] trial and python 2.5.2?

Jean-Paul Calderone exarkun at divmod.com
Sun Jul 13 20:23:31 EDT 2008

On Sun, 13 Jul 2008 18:34:47 -0400, Mikhail Terekhov <termim at gmail.com> wrote:
>I'm trying to run trial from twisted-8.1.0 on SuSE-11.0 with python 2.5.2 
>and get the following error
>(with super and old style classes IMHO). What would be the fix or workaround 
>for this?
>BTW on SuSE-10.3 with python 2.5.1 everything is OK.

Can you look at unittest.py from the standard library on each of these
systems and see if TestSuite is new-style or classic?  Note that it does
not subclass object, but the module has `__metaclass__ = type´, making
all classes that don't subclass something new-style.

TestSuite should be new-style - it is in my Python 2.5.1 installation
and it is in the 2.5 release branch.


More information about the Twisted-Python mailing list