[Twisted-Python] Python C API version mismatch when importing twisted

my list c2k_list at gmx.de
Mon Feb 18 18:42:53 EST 2008

I got an error message when I'm trying to import twisted in python2.5 on a Debian Lenny machine. The error is:

"RunetimeWarning: Python C API version mismacht for module _zoper_interface_coptimizations: This Python has API version 1013, moduel _zope_interface_coptimizations has version 1012." 

I installed python2.5 from source next to the standard debian python2.4 into /usr/local/lib/python2.5, redirect the link /usr/bin/python to /usr/local/bin/python2.5. Thats working, but when I try to import twisted with

"import twisted"

I receive the error above. Importing zope works just fine. All I found on the net was that there might be a problem with the two installations of python next to each other. But if so, how can I get rid of python2.4, because I need python2.5. Is there no chance to use both versions parallel?

The Version of the zopeinterface is 3.3.1-5, python is 2.4.4-7 and 2.5.1-6, twisted is 2.5.0-2.

I am fairly new to Debain and Python and I am really stuck. I hope someone can help me. I would appreciate it big time!

Psst! Geheimtipp: Online Games kostenlos spielen bei den GMX Free Games! 

More information about the Twisted-Python mailing list