[Twisted-Python] how to depend (in a setuptools sense) upon Twisted?

zooko zooko at zooko.com
Thu Apr 10 21:18:58 EDT 2008

On Apr 10, 2008, at 1:17 PM, Christopher Armstrong wrote:
> This may not be helpful, but it is additional data: Twisted
> subprojects are not easy_installable in any reasonable way.

This is relevant; thanks for the information.

  Brian Warner wrote:
> Another answer
> might be for the debian 'python-twisted' metapackage (which depends  
> upon
> python-twisted-core, python-twisted-web, etc) to provide an .egg- 
> info that
> claims to represent the 'Twisted' distribution, but I can imagine  
> problems
> with that.

What problems?  That's what Ubuntu Hardy currently does.  The "python- 
twisted" Debian package currently provides the "Twisted" distutils  
distribution, but it doesn't currently declare that it does so in a  
machine-readable way.



More information about the Twisted-Python mailing list