[Twisted-Python] Re: epoll reactor in Twisted 2.50 tarball

David Bolen db3l.net at gmail.com
Mon Sep 10 03:39:32 EDT 2007

"Alvin Delagon" <adelagon at gmail.com> writes:

> I have to install Twisted 2.50 on our Ubuntu Dapper servers. The problem is
> that I have to use the Twisted 2.50 tarball since Dapper apt repositories
> only have Twisted 2.40. The installation went smoothly and my twisted
> applications works except that when I try to run my scripts using the epoll
> reactor (twistd -ny ./myscript -r epoll) I get this error.
> (...)

When you built Twisted (through the setup.py script) it will build the
epoll reactor if it can find the /usr/include/sys/epoll.h header file.
So you might check if that is present on the system where you built
Twisted.  If not, you're probably missing some development packages.

On my Ubuntu feisty system the file comes as part of the libc6-dev

-- David

More information about the Twisted-Python mailing list