[Twisted-Python] Can I still run (most of) Twisted on Python 2.2?

Christopher Armstrong radix at twistedmatrix.com
Mon Mar 26 08:07:10 EDT 2007

On 3/26/07, Erik Forsberg <forsberg at cendio.se> wrote:
> In TwistedCore/setup.py, I find that python 2.3 is required for
> Twisted. I'd like to use Twisted for a project that currently requires
> only Python 2.2, which raises the question - which parts of Twisted
> requires 2.3, and how much of it can I run on Python 2.2?

Dunno. However, are you sure the library you're using won't run on
anything above Python 2.2? If so, is it a proprietary thing that you
can't change?

> On the same matter - are there any plans on when to stop supporting
> Python 2.3, Python 2.4, etc?

I think we've generally maintained a 5-year support for Python releases.

Christopher Armstrong
International Man of Twistery

More information about the Twisted-Python mailing list