[Twisted-Python] Debian package problems

Manlio Perillo manlio_perillo at libero.it
Thu Feb 22 09:32:16 EST 2007

Jean-Paul Calderone ha scritto:
> On Thu, 22 Feb 2007 14:21:18 +0100, Manlio Perillo 
> <manlio_perillo at libero.it> wrote:
>> Hi.
>> I have noted that the python-twisted package depends on 
>> python-twisted- words.
>> Is this really true?
>> For me this is a problem.
>> Today I have updated a Debian Etch server and an upgrade for 
>> python-twisted- words requires the installation of GTK and X11!
> python-twisted is a meta package which simply depends on all parts of 
> Twisted. If you don't want all parts of Twisted, you might want one of 
> the other
> packages.

Ok, thanks.

> As a separate issue, Twisted Words doesn't completely depend on GTK and 
> X11,
> only parts of it do.  You might suggest to the Debian maintainer that the
> dependencies for python-twisted-words are incorrect.

The maintainer has added the dependence for python-gtk-1.2 and 
python-glade-1.2 in the new version (0.4.0-2.1).

python-gtk-1.2, then, wants other packages, including x11-common.

For now I have solved downgrading the python-twisted-words to the 
previous version, holding it.

Regards  Manlio Perillo

More information about the Twisted-Python mailing list